Trying to input new suppressor into site

Home Forums General Site Help and Support Trying to input new suppressor into site

This topic contains 1 reply, has 2 voices, and was last updated by  Ed 3 weeks, 6 days ago.

  • Author
    Posts
  • #80704

    polak86
    Participant
    • Posts: 1
    Join Date: 10/12/2016

    I’ve just got approval for my Liberty Chaotic, and I see its not in the system. When I attempt to complete the data to request the model be input into the system, I keep getting, “There was a problem with your submission. Errors are marked below.”

    There is nothing marked. All fields and the reCAPTCHA is completed. Please advise.

  • #106946

    Ed
    Participant
    • Posts: 1
    Join Date: 10/12/2016

    I have also been trying to get two cans that are not listed added without success for about 6 months now.

    I’ve submitted that form twice, sent an email and used the “contact us” form and never received any sort of response back. Interestingly, the “form to add a product” is now telling me that my cans are “Blacklist Spam!” so it seems like my submissions were getting through… but they’re either backlogged or just being ignored. I’m not sure who runs this site its possible they are a small team.

    • This reply was modified 3 weeks, 6 days ago by  Ed.

You must be logged in to reply to this topic.

Write Reviews, Submit Tracking Data and More!

Subscribe to NFA Tracker, a community dedicated to tracking and reporting NFA transfer times as reported by users.

Join Now